Spotty Login Issues
Incident Report for Mozeo
Resolved
This issue has been resolved.
Posted Mar 22, 2022 - 11:50 EDT
Monitoring
A fix has been implemented and we will continue to monitor the situation.
Posted Mar 22, 2022 - 11:25 EDT
Identified
Our team has identified an issue that is causing some customers not to be able to log into their Mozeo accounts. We're working to resolve this as soon as possible.
Posted Mar 22, 2022 - 10:54 EDT
This incident affected: Dashboard.