Contacts Upload
Incident Report for Mozeo
Resolved
The contacts upload fix has been resolved.
Posted Apr 22, 2020 - 16:24 EDT
Update
Contacts upload is operational and we'll continue to monitor.
Posted Apr 22, 2020 - 15:35 EDT
Monitoring
Our contacts upload has been updated and we are monitoring the results.
Posted Apr 22, 2020 - 15:34 EDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 22, 2020 - 12:19 EDT
Identified
We are fixing an issue with the contacts upload section and it's currently unavailable.
Posted Apr 22, 2020 - 07:54 EDT
This incident affected: Dashboard.