Messaging Delays
Incident Report for Mozeo
Resolved
We see recovery with SMS and MMS to/from US and Canada networks from US Toll-Free and US long codes. We're resolving this incident, but we will continue to monitor for the next several hours.
Posted Jan 14, 2022 - 16:11 EST
Update
We and the carriers have observed a noticeable recovery after implementing a workaround. Still, we continue to see intermittent delivery delays sending and receiving Toll-Free SMS and MMS messages in US and Canada, along with a small subset of T-mobile traffic on US long codes. We will continue to monitor the situation and report back when we know more or it is resolved.
Posted Jan 14, 2022 - 15:34 EST
Monitoring
We are now observing some recovery in which some SMS and MMS to/from US and Canada networks from US Toll-Free and US long codes are being delivered. However, messages will continue to be delayed even while messages are getting delivered. Our engineers are continuing to work with our carrier partner to resolve the issue. We will provide another update as soon as more information becomes available.
Posted Jan 14, 2022 - 12:06 EST
Identified
We are experiencing delivery delays when sending SMS and MMS messages to US and Canada networks using Toll-free or long code numbers. Our engineers are working with our carrier partner to resolve the issue. We will provide another update as soon as more information becomes available.
Posted Jan 14, 2022 - 10:47 EST
This incident affected: Longcode Network and Toll-Free Network.