Delivery Delays
Incident Report for Mozeo
Postmortem

On December 7th at approximately 10:30 am ET, we were notified of a potential outage involving our infrastructure partner (AWS). This outage became worse throughout the day and resulted in an extended period of degraded performance.

We were part of a group of several thousand businesses that had issues. However, we managed to pool resources in other areas to ensure messages were being delivered and that parts of our service remained running throughout the day.

At this time, everything is back to normal and running smoothly.

Posted Dec 08, 2021 - 09:49 EST

Resolved
This incident has been resolved, and everything is running normally. We will continue to monitor results over the next several hours.
Posted Dec 07, 2021 - 21:03 EST
Update
We’re noticing better performance all around and are monitoring results towards full recovery.
Posted Dec 07, 2021 - 20:26 EST
Monitoring
A fix has been implemented and our server partner is slowly coming back to full capacity. We are continuing to monitor the situation and will post an update as soon as we know more.
Posted Dec 07, 2021 - 18:39 EST
Update
We are still experiencing issues across all services and message sending due to a server outage. We have identified the root cause and are actively working towards recovery.
Posted Dec 07, 2021 - 14:58 EST
Update
We are still experiencing elevated delivery delays. However, we have identified the root cause and are actively working towards recovery.
Posted Dec 07, 2021 - 12:16 EST
Identified
We're currently experiencing delivery delays. Our team is monitoring the issue and will post an update when we know more.
Posted Dec 07, 2021 - 11:51 EST
This incident affected: Dashboard, Shortcode Network, and Toll-Free Network.