T-Mobile/MetroPCS
Incident Report for Mozeo
Resolved
This incident has been resolved.
Posted 12 months ago. Sep 27, 2018 - 18:56 EDT
Investigating
We are experiencing SMS issues over short-codes to T-mobile & MetroPCS. We are working with the carrier to resolve this and will provide an update as quickly as possible.
Posted 12 months ago. Sep 27, 2018 - 14:45 EDT
This incident affected: Shortcode Network.