Contacts Upload
Incident Report for Mozeo
Resolved
This is resolved and we'll continue to monitor.
Posted Aug 12, 2022 - 11:03 EDT
Update
We are continuing to make background improvements to our contacts upload feature. Please use our exact template when uploading.
Posted Aug 11, 2022 - 08:34 EDT
Identified
An issue has been identified, and a fix is being implemented. For now, be sure to use our exact template for uploading, which can be found in your account.
Posted Aug 09, 2022 - 14:07 EDT
Investigating
We are currently investigating a potential issue with our contacts upload.
Posted Aug 09, 2022 - 13:18 EDT
This incident affected: Dashboard.