Outage
Incident Report for Mozeo
Resolved
This incident has been resolved.
Posted 9 months ago. Dec 12, 2018 - 15:36 EST
Monitoring
Our dashboard is operational again and we are monitoring the status.
Posted 9 months ago. Dec 12, 2018 - 15:24 EST
Identified
We're experiencing an outage with our dashboard. Our team is working to resolve this issue right away.
Posted 9 months ago. Dec 12, 2018 - 15:20 EST
This incident affected: Dashboard.