Toll Free SMS Delivery Delays to Multiple Networks in US and Canada
Incident Report for Mozeo
Resolved
This incident has been resolved.
Posted Aug 20, 2021 - 15:43 EDT
Monitoring
We're still experiencing toll-free SMS delivery delays to multiple networks in the US and Canada. We will update you as soon as we have more information.
Posted Aug 20, 2021 - 13:42 EDT
Identified
Our monitoring systems have detected an issue with toll-free SMS delivery delays to multiple networks in the US and Canada. Our engineering team has been alerted and is actively investigating. We will update in an hour or as soon as we have more information.
Posted Aug 20, 2021 - 12:16 EDT
This incident affected: Toll-Free Network.