Intermittent Inbox Delays
Incident Report for Mozeo
Resolved
An update has been implemented and we're monitoring its performance.
Posted Aug 11, 2021 - 15:53 EDT
Identified
We're currently experiencing intermittent inbox delays. Our team has identified the issue and is working through it. We'll keep you updated when we have more information.
Posted Aug 11, 2021 - 10:46 EDT
This incident affected: Dashboard.