Dashboard Icons
Incident Report for Mozeo
Resolved
This incident has been resolved!
Posted Apr 25, 2024 - 17:17 EDT
Identified
The issue has been identified, and we are working with the partner to resolve it.
Posted Apr 25, 2024 - 15:28 EDT
Investigating
We're currently experiencing an issue with our dashboard icons. We are investigating this issue and will update you as soon as we know more.
Posted Apr 25, 2024 - 15:06 EDT
This incident affected: Dashboard.