Contacts Data
Incident Report for Mozeo
Resolved
This incident has been resolved.
Posted Apr 22, 2020 - 07:53 EDT
Monitoring
A fix has been implemented and we're monitoring.
Posted Apr 21, 2020 - 20:55 EDT
Identified
We have found an issue with our contact data not showing the correct first and last name. Our team has identified the issue and is working on a fix.
Posted Apr 21, 2020 - 18:54 EDT
This incident affected: Dashboard.