Icon not loading
Incident Report for Mozeo
Resolved
This incident has been resolved.
Posted May 30, 2023 - 15:26 EDT
Monitoring
Icons are showing again correctly. We will continue to monitor the incident.
Posted May 30, 2023 - 14:45 EDT
Investigating
We are currently investigating an issue with icon graphic loading.
Posted May 30, 2023 - 13:38 EDT
This incident affected: Homepage and Dashboard.