Shortcode Delivery Delays
Incident Report for Mozeo
Resolved
This incident has been resolved.
Posted Feb 12, 2020 - 14:00 EST
Monitoring
We're seeing a recovery in the delivery of shortcode messages to US carriers. We'll continue monitoring and provide further updates as necessary.
Posted Feb 12, 2020 - 13:18 EST
Investigating
We are experiencing shortcode delivery delays and failures for some messages towards all carriers in the US. We are working with our carrier partners to resolve this issue. We will provide further updates as soon as they become available.
Posted Feb 12, 2020 - 12:05 EST
This incident affected: Shortcode Network.