Bulk Messaging & Inbox
Incident Report for Mozeo
Resolved
This incident has been resolved.
Posted Aug 03, 2021 - 10:27 EDT
Monitoring
Fixes have been implemented, and we're monitoring the results.
Posted Aug 03, 2021 - 09:31 EDT
Identified
We are currently working on an issue with outbound bulk messaging and inbox delays.
Posted Aug 03, 2021 - 08:46 EDT
This incident affected: Dashboard, Shortcode Network, Longcode Network, and Toll-Free Network.