Intermittent Inbox Errors
Incident Report for Mozeo
Resolved
This issue has been resolved. We'll continue to monitor as needed.
Posted Aug 03, 2021 - 13:30 EDT
Identified
We've noticed some intermittent inbox errors. Our team is working on a fix and will update you when we have more information.
Posted Aug 03, 2021 - 10:35 EDT
This incident affected: Dashboard.